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Joining the PROLITH Users-Only 
Website

This section describes how to get access to the PROLITH users-only 
website. You must have access to the website to perform the procedures in 
this guide and to download PROLITH papers and training materials.

1.  Go to http://www.kla-tencor.com/usersonly.

2.  Click Create an account.

3.  In the Email field, type your email address and click Submit.

4.  Enter your information in the fields on the screen and click Submit.

5.  When you receive a “KLA-Tencor Users Only - Account Request 
Approved” email from KLA-Tencor, click the first link in the email.

6.  In the Email Address field, type your email address and click Submit.

7.  When you receive a “Your KLA-Tencor Users Only password reset 
request” email, click the link in the email.

8.  In the Setup or Reset Your Password window’s Username field, type 
your email address. 

The Verification Code was automatically pasted into its field.

9.  Click Submit.

10. In the Lost Password window’s Password field, type the password you 
would like to use to get to the users-only site.

11. In the Confirm Password field, retype the password.

12. Click Submit. 

A message displays indicating that your password was successfully 
reset. 

13. Follow these steps to log in to the users-only website: 

a. Go to http://www.kla-tencor.com/usersonly.

b. In the Username field, type your email address.

c. In the Password field, type the password you created.

d. Click Log in.



Install and Configure PROLITH

This section describes the steps to download and install PROLITH or 
PROLITH Enterprise 2020a, and the steps to configure and use a 
stand-alone system the first time and each time you install an upgrade.

Note: To perform the procedures in this section, you must have local 
administrator privileges.

PROLITH General Information

Minimum System Requirements

The following list shows the minimum system requirements for PROLITH 
installation:

• 2.0 gigahertz (GHz) or faster AMD or Intel 64-bit multicore processor, 
with one to 16 cores

• One of the following operating systems:

– Microsoft Windows 10 Enterprise (64-bit)

– Microsoft Windows Server 2016 (64-bit)

– Microsoft Windows Server 2019 (64-bit)

• 8 GB of RAM

• 120 GB or more of disk space on the drive where you install PROLITH 

• A display with a resolution capable of displaying 1024 x 768 pixels, true 
color (32 bit) or higher

• Microsoft Internet Explorer v11.0 or later
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PROLITH General Information
Recommended System Configuration

For optimal performance, we recommend the following system 
configuration. 

• One of the following operating systems: 

– Microsoft Windows 10 Enterprise (64-bit)

– Microsoft Windows Server 2016 (64-bit)

– Microsoft Windows Server 2019 (64-bit)

• A latest-generation, workstation-grade multicore processor with at least 
8 cores 

• 16 GB or more of RAM for a laptop and 64 GB or more for a desktop 
configuration

If your computer does not meet the recommended configuration, you can 
still run PROLITH, but simulations will be slower. A high-performance 
system may be necessary to run large-scale simulations.

PROLITH Programming Interface (PPI) Recommended 
System Configurations

For information about using scripting for PPIs, see “Using Scripting in 
PROLITH” on page 8.

• If you are using the PPI with the Visual Basic environment, you must 
have Microsoft Excel 2007 or later. Because Visual Basic for 
Applications (VBA) is the programming language for Microsoft Excel, 
Excel includes options for using VBA macros and code. 

• If you are using the PPI with the MATLAB environment, we recommend 
MATLAB v2018a or later. Some of the MATLAB commands in the PPI 
examples might not work with older versions of MATLAB. 

• If you are using the PPI with multiple PROLITH versions, you need to 
perform certain steps to switch between versions. For more information, 
see the PROLITH Help.
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Install PROLITH
PROLITH License Configuration Options

For information on concurrent licensing, please refer to the section on 
Configuring a Licensing Server for a Concurrent System.

PROLITH Installation Directory

The default installation directory for PROLITH is C:\Program Files\
PROLITH_Toolkit\PROLITH 2020a.

The default installation directory for PROLITH Enterprise is C:\Program 
Files\PROLITH_Toolkit\PROLITH Enterprise 2020a. 

Install PROLITH

1.  To install the PROLITH version that you downloaded to your desktop, 
double-click the icon for the PROLITH_2020a_Install.exe or 
PROLITH_Enterprise_2020a_Install.exe file.

2.  If a Security Warning pop-up window opens, click Run.

3.  Follow the instructions on the screen.

4.  When the installation is complete, close the installer without opening 
PROLITH.

Note: If the installation prerequisite(s) require a reboot, or if the installation 
does not resume on startup, manually start the installation again to 
resume.

Stand-Alone Licensing Concurrent Licensing

• Each computer has PROLITH software 
installed.

• Each PROLITH license is tied to and 
installed on a specific computer. 

• The computer does not need to be 
connected to the network to run 
PROLITH.

• If users remotely access a PROLITH 
computer, only one user at a time can run 
PROLITH remotely.

• Each computer has PROLITH software 
installed. 

• The license server can be located 
anywhere as long as the computers can 
access it over the network. 

• Each computer must be connected to the 
network to run PROLITH.

• Each instance of PROLITH running on a 
computer uses one license from the 
server. For example, if the server 
supports three licenses, then three users 
can simultaneously run PROLITH. 
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Get a Stand-Alone License
Get a Stand-Alone License

Note: To install a License Server for PROLITH or PROLITH Enterprise, 
refer to the section on Configuring a Licensing Server for a 
Concurrent System.

License Manager Installation Directory

The default installation directory for the license manager is

C:\Program Files(x86)\FlexNet Publisher License Server 
Manager

New License

Note: If you do not have a valid license, or if your license has expired, you 
must follow the steps in this section to request a new stand-alone 
license.

1.  After installation, open the Microsoft Windows start menu and, in the 
list of programs, select PROLITH Toolkit Utilities -> PROLITH 
Toolkit License Administrator. 

2.  Click File -> New Request.

A Save dialog appears.

3.  Save the file in a convenient location, such as your desktop. The default 
name shows as computername.request.

Note: If you don’t accept the default name, be sure to choose a name you 
can remember that makes sense for your environment.The same file 
name with a different extension will be returned to you. 

4.  Email the file that you created to 
DL-CP-License-Admin@kla.com.

5.  When you receive the computername.license file from KLA, 
save the file to your desktop.

6.  Open the Microsoft Windows start menu and, in the list of programs, 
select PROLITH Toolkit Utilities -> PROLITH Toolkit License 
Administrator.

7.  Perform one of the following steps:

– Drag the .license file into the Fulfillments pane of the license 
administrator window.

– Click File -> Process Response, then browse to desktop and select 
the .license file.

The status in the license administrator window indicates success and 
shows the license information.
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Troubleshooting
Replacement License

To install the PROLITH or PROLITH Enterprise 2020a software on a 
different computer in the future, you must request a new license. Follow the 
steps in this section to get the new license.

1. Open the Microsoft Windows start menu and, in the list of programs, 
select PROLITH Toolkit Utilities -> PROLITH Toolkit License Admin-
istrator.

2. In the Fulfillments pane of the license administrator window, select the 
fulfillment for the PROLITH or PROLITH Enterprise 2020a license.

3. Select Delete.
4. In the Delete confirmation window, select OK.
5. Select a location and save the Delete confirmation message.
6. Email the Delete confirmation file that you created to 

DL-CP-License-Admin@kla.com, and then request a new license.

If you experience any issues with installation or licensing, please refer to the 
table below for information on contacting technical or commercial support.

Troubleshooting

Stand-Alone License

Problem: Although PROLITH started yesterday, today it will not start and 
issues a message about licensing.

Solution: You might have been using a temporary training license, or your 
license might have expired. To get a new license, send an email message to 
DL-CP-License-Admin@kla.com.

Country Contact Information

Global Online Form to Submit PROLITH Questions: 

https://www.kla-tencor.com/contact/technical-supp

ort-request

Note: Because requests for information made through the online 
form enter a tracking system, we strongly recommend that you use 
this contact method for technical support. 

All Regions Company: KLA, Inc.

Email address: Tech_Support@kla.com
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Troubleshooting
Databases

Problem: I upgraded PROLITH, and the files I previously saved in my 
database are not in the new database.

Solution: Use one of the following methods to resolve this problem:

• To configure PROLITH to use the old database instead of the new 
database:

a. Start PROLITH.

b. Select File -> User Preferences.

c. In the Database Location field, select the old database.

d. Click OK.

• To merge the old and new databases, open the PROLITH 2020a Help and 
perform the “Merge Databases” procedure.
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Add PPI Functionality in VBA
Using Scripting in PROLITH

The PROLITH Programming Interface (PPI) is the application 
programming interface (API) for PROLITH. You can use the PPI to access 
PROLITH functionality from other applications without using the GUI. 
You can also use the PPI to simplify some tasks that might be tedious to 
perform in the GUI. You can add this PPI functionality to the scripting 
environment for Visual Basic for Applications (VBA) and for MATLAB.

Add PPI Functionality in VBA

If you plan to use the PROLITH Programming Interface (PPI) with VBA, 
you must add a reference to the Prolith.exe file.

Follow these steps for each script file that will contain a PPI macro:

1.  Start the application you used to create the file, usually Microsoft Excel.

2.  Follow these steps to start the Visual Basic Editor on Microsoft Office 
2007 or later:

a. Click the Developer tab.

If the Developer tab is not available, refer to the Microsoft Excel 
documentation for steps to display the tab.

b. Click Visual Basic.

3.  Select Tools -> References.

4.  In the Available References list, look for a Prolith check box.

5.  If you see the check box, proceed to step 6. 

If you do not see the check box, perform the following steps to add the 
Prolith check box to the list:

a. Click Browse.

b. In the Files of type list, select All Files.

c. Navigate to the PROLITHInstallationDirectory\
PROLITH X6.1\Prolith.exe file. 

For the location of the directory, see “PROLITH Installation 
Directory” on page 2.

d. Click Open.

6.  Select the Prolith check box and click OK.
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Add PPI Functionality in MATLAB
Add PPI Functionality in MATLAB

If you plan to use the PROLITH Programming Interface (PPI) with 
MATLAB, you must add the PPI functionality in MATLAB.

1.  In MATLAB, select Home -> Set Path.

2.  Click Add Folder.

3.  Navigate to PROLITHInstallationDirectory\PROLITH 
X6.1\MatLabPPI. 

For the location of the installation directory, see “PROLITH Installation 
Directory” on page 2.

4.  Click Save.
PROLITH Getting Started Guide 9



Configuring a Licensing Server for a 
Concurrent System

This chapter describes the steps you follow to configure a Windows or 
Linux licensing server. You also learn how to get and install a PROLITH 
license. 

Note: With a concurrent system, you can install PROLITH on an unlimited 
number of clients, but the number of users who can simultaneously 
run PROLITH is limited to the number of users supported by the 
concurrent license.

Configure a Microsoft Windows Licensing 
Server

If your licensing server has a Microsoft Windows operating system, follow 
the procedures in this section to configure the licensing server. If you are 
instead using a Linux server, see “Configure a Linux Licensing Server” on 
page 14.

Note: To perform the procedures in this section, you must have local 
administrator privileges.

Install the License Manager on the Windows Licensing Server

You use the FlexNet License Administrator and FlexNet Publisher software 
to administer the licensing server for PROLITH. Follow these steps to 
install the current version of the license software.

1.  Download the license manager software:

a. Go to the PROLITH users-only website at 
http://www.kla-tencor.com/usersonly and log in.

If you do not have a password for the users-only website, see 
“Joining the PROLITH Users-Only Website” on page 1.

b. Click Downloads -- Products & Utilities.

c. Scroll down to the Utilities section.

d. Under Network License Manager, click PROLITH Toolkit 
License Server (Windows).

e. Enter all required information and click Submit.
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Configure a Microsoft Windows Licensing Server
f. When you receive an approval email from KLA, click the link in the 
email.

g. Save the software to the location of your choice on the licensing 
server.

2.  Double-click the PROLITHToolkitLicenseServerSetup file.

The setup wizard starts.

Note: The installation requires that you have certain files installed on your 
system. If those files are not present, an installation window opens 
before setup starts. Click Install to install the files. The install window 
closes when the process is finished.

3.  Click Next.

4.  After reading and accepting the License Agreement, click Next.

5.  Depending on whether FlexNet Publisher License Services is already 
installed on your system, select or clear the Install the FlexNet 
Publisher License Service check box.

You must have FlexNet Publisher License Services to be able to run the 
PROLITH Toolkit License Server software.

6.  Click Next.

7.  In the installation window, click Install.

The PROLITH Toolkit License Server items are installed.

8.  Click Finish to close the wizard.

Install the FlexNet Publisher License Service

If you selected the Install the FlexNet Publisher License Service check 
box in step 5 of “Install the License Manager on the Windows Licensing 
Server,” the initial installation window opens.

Note: If you did not choose to install the FlexNet Publisher License Server, 
your installation steps are done and you can skip to “Set Up and Start 
the Service” on page 12.

1.  Click Next.

2.  Accept the default installation path, or enter your preferred path, and 
click Next.

Note: You will need the installation path information later in this 
configuration.

3.  Accept the default data folder path, or enter your preferred path, and 
click Next.
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Configure a Microsoft Windows Licensing Server
4.  Perform one of these steps:

– If you have other licenses served by the FlexNet Publisher on this 
server, select the Import check box, browse to and select your 
installation path and data folder path, and click Next

– If you do not have any other licenses served by the FlexNet Publisher 
on this server, ignore these settings and click Next. 

5.  Click Install.

6.  The next window pertains to the Visual C++ 2010 Redistributable 
Package. You do not need to install this package, so ignore the check 
box and click Next.

7.  Perform one or more of the following steps to enter port numbers:

a. If there is no conflict using HTTP Port Number 8090 for the web 
service, leave the setting at the default 8090. 

b. If port 8090 is already in use by another web application, change the 
port number to an available port number. 

c. If the license service must be on a specific port, enter a value for the 
License Server Port Number.

8.  Click Next.

9.  Unless you require a specific default timeout values, alert values, or 
restart retries, leave the default settings and click Next.

10. Ensure that the Run as a service check box is selected.

11. The Service name is the name of the service that will run to host the 
server license. You can accept the default or enter a specific name.

12. If needed, enter the number of seconds to delay on a system restart.

13. Click Next.

14. Click Done.

15. If prompted, restart your system and then set up and start the service.

Set Up and Start the Service

1.  Go to the PROLITH Toolkit License Server installation folder:

The default location is here:

C:\Program Files (x86)\PROLITH_Toolkit\PROLITH 
Toolkit Licensing Server

2.  Copy the PROLITH.exe and PROLITH_libFNP.dll files to the 
FlexNet Publisher installation path you chose in step 2 of “Install the 
FlexNet Publisher License Service.” 
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Configure a Microsoft Windows Licensing Server
The default location is here:

C:\Program Files (x86)\FlexNET Publisher License 
Server Manager

3.  Go to Windows Services, locate the lmadmin service or service name 
you entered, right-click it, and click Start. It usually takes 45-60 
seconds to start. 

4.  Add the PROLITH license to FlexNet Publisher, as described on “Add 
the PROLITH License to FlexNet Publisher” on page 17.

5.  Get your PROLITH license.

Get the Concurrent PROLITH License for the Windows 
Licensing Server

1.  On the license server system, open the Microsoft Windows start menu 
and, in the list of programs, select PROLITH Toolkit -> PROLITH 
Toolkit Server License Utility.

Note: Depending on the type of server you use, the path you follow to open 
the PROLITH Toolkit Server License Utility might be different.

2.  Click File -> New Request.

A Save dialog appears.

3.  Save the file in a convenient location, such as your desktop. The default 
name shows as <computername>.request. 

Note: If you don’t accept the default name, be sure to choose a name you 
can remember that makes sense for your environment.The same file 
name with a different extension will be returned to you. 

4.  Email the file that you created to 
DL-CP-License-Admin@kla-tencor.com.

5.  When you receive the <computername>.license file from 
KLA-Tencor, save the file to your desktop.

6.  If the PROLITH Toolkit Server License Utility is not already open, open 
it using the same method as in step 1.

7.  Perform one of the following steps:

– Drag the .license file into the Fulfillments pane of the License 
Utility.

– Click File > Process Request, then browse to desktop and select the 
.license file.

The status in the License Utility Fulfillments window indicates success 
and shows the license information.

8.  Close the PROLITH Toolkit Server License Utility.

9.  Start the PROLITH vendor daemon, as described on page 20.
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Configure a Linux Licensing Server
10. Configure the client system to use the licensing server.

Configure Firewalls for the Windows Licensing Server

You can configure firewalls to allow the PROLITH client computers to 
access the licensing server.

If you need help configuring the firewalls, contact your IT department, or 
refer to “Appendix A: Specifying Exceptions for Firewalls” on page 24.

Note: By default, FlexNet Publisher License Server uses port 8090 as its 
administration port. Be sure that administration port 8090 is open.

Configure a Linux Licensing Server

If your licensing server has a Linux operating system, follow the procedures 
in this section to configure the licensing server. If you are using a Windows 
server, see “Configure a Microsoft Windows Licensing Server” on page 10.

Note: To perform the procedures in this section, you must be logged in as 
root. 

Packages to be Installed

When you run the installer, you install the following packages:

• Flexera Trusted Storage Service

• Flexera FlexNet Publisher License Server

• PROLITH Vendor Daemon

• PROLITH_server_tsadmin utility

Install the License Manager on the Linux Licensing Server

These steps describe how to install the license manager for Linux systems.

1.  Follow these steps to download the FlexNet Publisher License Server 
software:

a. Go to the PROLITH users-only website at 
http://www.kla-tencor.com/usersonly and log in.

If you do not have a password for the users-only website, see 
“Joining the PROLITH Users-Only Website” on page 1.

b. Click Downloads -- Products & Utilities.

c. Scroll down to the Utilities section.
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d. Under Network License Manager, click PROLITH Toolkit 
License Server (Linux).

e. Enter all required information and click Submit.

f. When you receive an approval email from KLA, click the link in the 
email.

g. Save the software to the location of your choice on the licensing 
server.

2.  If a shell is not started, start a shell.

3.  To change to the directory where you saved FlexNet Publisher License 
Server, type the following command:

cd DirectoryName

4.  Start the installation of the FlexNet Publisher License Server software 
by typing the following command on one line:

sh 
PROLITHToolkitLicenseServerSetup-x86_64-Version.sh, 
where Version is the License Server version. The format will be:

PROLITHToolkitLicenseServerSetup-x86_64-XX_XX.sh

Run this command to start the standard installation of all packages 
mentioned in “Packages to be Installed” on page 14.

Note: This command begins the installation of everything shown in 
“Packages to be Installed” on page 14. However, if you want to see 
what other installation options are available to you, run the sh 
PROLITHToolkitLicenseServerSetup-x86_64-Version.sh 
--help command instead.

5.  After reading the license agreement, enter y to accept it and press Enter.

If you only press Enter, you are canceling the installation.

6.  Enter a user account name and press Enter. 

If you only press Enter, you accept the default account name of 
lmadmin.

Note: We recommend that you run the license server from an account 
without administrative privileges. 

7.  Enter an installation directory and press Enter. 

If you only press Enter, you accept the default installation directory.

8.  Enter a port number and press Enter. 

If you only press Enter, you accept the default port.

The installation finishes and creates a directory for log files in the tmp 
directory. These log files describe all of the commands that ran during 
installation.
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You must get a PROLITH license before you can use the software. See “Get 
the Concurrent PROLITH License for the Linux Licensing Server” on 
page 16.

Get the Concurrent PROLITH License for the Linux Licensing 
Server

Note: If do not have a valid license, or if your license has expired, you must 
follow the steps in this section to request a new concurrent license.

If you need to install the FlexNet Publisher License Server software 
on a different computer in the future, you must request a new license. 
In such cases, email 
DL-CP-License-Admin@kla-tencor.com to ask for a COPO 
Disable form so that the license on the old computer can be 
deactivated. Then request a new license.

1.  On the licensing server, type the following command:

PROLITH_server_tsadmin -r license.request

Note: If you don’t use the default name, be sure to choose a name you can 
remember that makes sense for your environment.The same file 
name with a different extension will be returned to you. 

2.  Email the license.request file you just created to 
DL-CP-License-Admin@kla-tencor.com.

3.  When you receive the license.license license file from 
KLA-Tencor, process the license by typing the following command:

PROLITH_server_tsadmin -p license.license

You can view the licenses in the trusted storage server by typing the 
following command:

PROLITH_server_tsadmin -v

4.  To proceed with the installation, configure the PROLITH daemon port, 
as described in step 6 of “Configure Port Numbers on the Server” on 
page 21.

5.  Start the PROLITH vendor daemon, as described on page 20.

6.  Configure the client system, as described on page 22.

Configure Firewalls for the Linux Licensing Server

Configure firewalls to allow the PROLITH client computers to access the 
licensing server.

If you need help configuring the firewalls, contact your IT department, or 
refer to “Appendix A: Specifying Exceptions for Firewalls” on page 24.
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Note: Be sure that administration port 8090, or the port you configured in 
“Install the License Manager on the Linux Licensing Server” on 
page 14, is open.

Configure the Flexera License Server

You can configure the Flexera license server using a Windows or a Linux 
system. Follow the steps in each section to set up this license server.

Add the PROLITH License to FlexNet Publisher

If you do not have a PROLITH license already installed, follow these steps 
to install it:

1.  Open a web browser.

2.  Navigate to the port you configured for the license server in step 7 of 
“Install the FlexNet Publisher License Service” on page 11.

If you changed the port from 8090 to a different value for the web 
interface, change the URL to match the correct port. For example, if you 
changed the web port to 8022, navigate to http://localhost:8022.

3.  In the upper right, click Administration to open the Sign In window 
shown in Figure 1.

Figure 1:  FlexNet Publisher Sign In Window
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4.  Complete the fields to sign in:

a. For User Name, type admin.

b. For Password, type admin.

Note: The first time you sign in, you must complete additional fields to 
change the password.

c. Click Submit.

5.  Click the Vendor Daemon Configuration tab to display the window 
shown in Figure 2.

Figure 2:  Vendor Daemon Configuration Tab

6.  Click Import License to display the window shown in Figure 3.

Figure 3:  Import License into FlexNet Publisher

7.  Click Browse and perform one of the following steps:

– For Windows systems, navigate to C:\Program Files 
(x86)\PROLITH_Toolkit\PROLITH Toolkit 
Licensing Server.
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– For Linux systems, follow these steps:

i. Download the 
PROLITHToolkitLicenseServerSetup-x86_64-Version
.sh file.

ii. Run this command on one line:

PROLITHToolkitLicenseServerSetup-x86_64-Version
.sh -unpack

iii. Navigate to the /tmp directory.

8.  Select PROLITH.lic.

9.  Ignore the Overwrite License File on License Server check box and 
leave it cleared.

10. Click Import License.

11. On the next window, click OK.

The PROLITH daemon now appears in the Vendor Daemons list, but 
you must get a PROLITH license before you can start the daemon.

Figure 4:  PROLITH Daemon in the Vendor Daemons List

12. Refer to one of these sections and follow the steps to get a license:

– “Get the Concurrent PROLITH License for the Windows Licensing 
Server” on page 13

– “Get the Concurrent PROLITH License for the Linux Licensing 
Server” on page 16
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Start the PROLITH Vendor Daemon

You must start the PROLITH vendor daemon before you can run 
PROLITH. Complete these steps to start the daemon:

1.  Complete one of the following steps:

– If FlexNet Publisher is not already open, open a web browser and 
continue with step 2.

– If FlexNet Publisher is already open, skip to step 5.

2.  Navigate to the port you configured for the license server in step 7 of 
“Install the FlexNet Publisher License Service” on page 11.

For example if you accepted the default 8090 port, you would navigate 
to http://localhost:8090 or http://127.0.0.1:8090.

3.  Click Administration to open the Sign In window.

4.  Complete the fields to sign in.

5.  Click the Vendor Daemon Configuration tab to display the list of 
Vendor Daemons shown in Figure 5. 

Figure 5:  FlexNet Publisher Vendor Daemons Window

6.  In the PROLITH row, click Administer.

7.  In the setup window, leave the default settings and click Start. 

The status of the daemon changes to Up. You might need to click 
another tab and then click Vendor Daemon Configuration again to see 
the status change. 

8.  Close FlexNet Publisher.
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Configure Port Numbers on the Server 

You can configure the license server port and the PROLITH vendor daemon 
port. If you are using PROLITH on a Linux system, you must configure the 
PROLITH vendor daemon port. 

To configure port numbers on the server, go to the licensing server and 
follow these steps to do so:

1.  Open a web browser.

2.  Navigate to the port you configured for the license server in step 7 of 
“Install the FlexNet Publisher License Service” on page 11.

3.  Click Administration to open the Sign In window.

4.  Complete the fields to sign in.

5.  To change the license server port, follow these steps:

a. On the Administration page, click the Server Configuration tab.

b. Click the License Server Configuration title to open the section, as 
shown in Figure 6.

Figure 6:  License Server Settings of Server Configuration

c. Click the Use this port radio button and enter the port number you 
want to use. 

Note: This is the port used by the lmadmin.exe utility.

d. Click Save.
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6.  To change the port for the PROLITH vendor daemon, follow these 
steps:

a. On the Administration page, click the Vendor Daemon 
Configuration tab.

b. Click the PROLITH daemon in the list and go to the General 
Configuration section, as shown in Figure 7.

Figure 7:  General Configuration Settings of Vendor Daemon Configuration

c. Click the Use this port radio button and enter the port number you 
want to use. 

d. Click Save.

7.  Restart the license server to make sure services use the new ports you 
specified.

If you changed the port for the lmadmin.exe utility, follow the steps in 
“Configure a Client to Use the License Server” to update the license 
administrator.

Note: You can also view the server logs on the Vendor Daemon 
Configuration page by clicking the Vendor Daemon Log section and 
then clicking View file externally.

Configure a Client to Use the License Server 

On the client system where you want to run PROLITH X6.1, install 
PROLITH, as described in “Install PROLITH” on page 4.

Then follow these steps to configure the client. You also follow these steps 
to configure the license path when you use ports other than the default.

1.  Open the Microsoft Windows start menu and, in the list of programs, 
select PROLITH Toolkit -> PROLITH Toolkit License 
Administrator. 
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2.  Select File -> Edit License Path and click the top of the window to 
enable editing. 

A dialog with a list of paths appears.

3.  Double-click the blank line below the last path and enter the server name 
as @<server_name>.

For example, if the server is named licenseserver, you would 
enter @licenseserver, 

4.  If a special port has been configured on the license server, enter the 
following information: 

port number@<machine name> or <IP address of 
license server>

For example, you might enter 27000@10.0.0.1.

Note: Port number 27000 is the default port. If you leave the default port 
number configured, you do not need to enter it in this path, but you 
must still include the @ symbol with the machine name. For example, 
you might enter @10.0.0.1. If you change the default port, you must 
include the new port number in the path.

5.  Click OK.

6.  Close the license administrator window.

7.  Start PROLITH.

If you want to use scripting, see “Using Scripting in PROLITH” on page 8.
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Appendix A: Specifying Exceptions for 
Firewalls

Follow the instructions in this appendix when you need to specify 
exceptions for firewalls on Windows or Linux systems.

Windows Firewall Exceptions

If your licensing server has a Microsoft Windows operating system and you 
have enabled the Windows firewall, this section describes how to configure 
the Windows firewall to allow PROLITH client computers to access the 
licensing server. This section how to specify exceptions for the firewall on 
Windows 7, Windows 10, Windows Server 2008, Windows Server 2012, 
and Windows Server 2016. Some of the steps differ between operating 
systems.

1.  To open the Windows Firewall, navigate to the Control Panel.

2.  In the address bar at the top of the window, type the following text:

C:\WINDOWS\System32\Firewall.cpl

3.  Follow these steps to allow clients access to the licensing server:

a. On the left side of the window, click Allow a program or feature 
through Windows Firewall.

Note: This link might show Allow an app or feature through Windows 
Firewall.

b. If the Allow another program or Allow another app button is not 
available, click Change settings.

c. Click Allow another program or Allow another app.

d. Click Browse.

e. Navigate to the 
LicenseMgrInstallationDirectory\FlexNet 
Publisher License Server\lmadmin.exe file and click 
Open. 

For the location of the installation directory, see “License Manager 
Installation Directory” on page 5.

f. Click Add.
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g. As shown in Figure 8, the display name of the application changed 
to Flexera Software LLC, but it is still the lmadmin.exe 
application. Make sure the row is selected. 

Figure 8:  Windows Firewall Allowed Programs with lmadmin selected

h. Select all of the network connection type check boxes that are 
shown, such as Private, Public, and Domain.

i. Click Allow another program or Allow another app.

j. Click Browse.

k. Navigate to the 
LicenseMgrInstallationDirectory\FlexNet 
Publisher License Server\prolith.exe file and click 
Open.

l. Click Add.
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m. As shown in Figure 9, make sure PROLITH daemon is selected.
 

Figure 9:  Windows Firewall Allowed Programs with PROLITH selected

n. Select all of the network connection type check boxes that are 
shown, such as Private, Public, and Domain.

o. Click OK.

You can also set up a port-based exception list for your firewall for the port 
numbers associated with the lmadmin and prolith processes.
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Red Hat Enterprise Linux (RHEL) Firewall 
Exceptions

If your licensing server has a Linux operating system, use this section to 
configure those firewalls to allow PROLITH client computers to access the 
licensing server. 

In these example, computers that have PROLITH installed reside in the 
public zone. If the computers that are requesting licenses reside in 
another zone, substitute the name of that zone for public.

• You can enter the following command on one line to allow incoming 
traffic on port 8090 on a RHEL 7 machine. Port 8090 is the port that the 
web-based administration listens on:

firewall-cmd --permanent --zone=public 
--add-port=8090/tcp

• You can use the following command to allow incoming traffic on port 
27000-27009 on a RHEL 7 machine. For a default configuration, the 
license server listens on ports 27000 through 27009 when serving 
licenses:

firewall-cmd --permanent --zone=public 
--add-port=27000-27009/tcp

• You can use the following command to allow incoming traffic on port 
prolithport on a RHEL 7 machine, where prolithport is the value selected 
during configuration of the Flexera License Server. Refer to step 6 of 
“Configure Port Numbers on the Server” on page 21 for the instructions, 
then run this command:

firewall-cmd --permanent --zone=public 
--add-port=prolithport/tcp

• After making changes to the firewall, run the following command to 
update the firewall: 

firewall-cmd --reload
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