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1. LAYOUT BEAMER OVERVIEW 
 
 
Layout BEAMER provides a new innovative GUI framework for the database driven, 
modular design of complex layout process flows. Start Layout BEAMER by logging into 
korat or minx using the icons on your desktop. On Windows, also start X-Windows, 
either Exceed or XMing. By typing LayoutBEAMER at the prompt you will see the 
following main window appear: 
 

 
 
The Layout BEAMER Graphical User Interface (GUI) consists of the left side Tool 
Window pane, the main Process Flow Design workspace window pane, and the lower 
Information Window pane. Within the Tool Window pane’s Module library under the 
Edit Tab, you see all available process modules in the following groups:  
- Layout Process modules (Import, Export, Extract, Transform, PEC) 
- Data Prep modules (Heal, NOT, Bias, P-XOR, MINUS, OR, AND, XOR) 
- Modeling modules (E-Beam, Resist) 
- Control modules (If, Loop, Merge, Split) 
The Tool Window pane also has User Flows & Central Flow Tabs, where common 
user-defined process flows can be stored to build up a database for later retrieval and 
re-use. 
 
Building a Process Flow is simply done by drag & drop (using the left mouse button) 
of the desired process modules from within the Edit Tab (Module Library) into the 
Process Flow Design workspace window or double click on the desired process 
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Module and it will automatically be connected to the last Module added into the Process 
Flow Design workspace. 
 
Module Status 
The status of a module is shown by the module color and the icon marker located at the 
right side of the module. A module which has not had its parameters set is identified as 
an orange colored module, whereas a red color and a triangular-shaped Run To button 
signifies that parameters have been set but the module has not been run yet. A module 
which has been run and the results are ready, is shown with an overlapping-box View 
icon. A progress bar is shown while the process is being computed . If a module has 
been selected with the mouse or with the Ctrl-A command, it will have four red dots 
surrounding the module. Moving your mouse over a module will display the module 
name and any comments that have been assigned to that module. 
 

 
 
Single Port Modules 
A port is used to connect modules. There are input and output ports. A single port 
module has only one port at the bottom center of the module signifying that it has only 
output connectivity capability. It can be connected to another module, but has no input 
capability within the flow. A module's ports are identified as a small, white-colored box. 

 
 
Dual Port Modules 
A dual port module has a connectivity port at both the top and bottom center of the 
module, signifying that it has both input and output connection capability in a flow. 
 

 
 
Dual port modules include: Extract, Filter, Transform, Grid, Heal, NOT, Bias, P-XOR, 
PEC, Shape-PEC, 3D PEC, FDA, Export, E-Beam and Metrology. 
 
Multi Port Modules 
A multi port module usually has three ports with a few exceptions. The multi port 
modules have two input ports at the top on the module and one output port on the 
bottom. Some specialty modules will have one input and two output modules while 
others, such as Loop and Optimizer, will combine two modules as a single process, 
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each with input and output connectivity capability. The other exception is the new Merge 
and Split modules which transform into a hub with a dynamic number of ports. 
 

 

 

 
Multi port modules include: OR, MINUS, AND, XOR, Split, Merge, Loop and Optimizer. 
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How To Connect Modules 
There are three ways to connect modules. Drag and drop a module from the library onto 
the target module in the flow until the small white connection port turns black, then 
release the mouse and the modules will be connected. Modules can also be manually 
connected by using the right mouse button, held down, to draw a line between open 
ports. Finally, double clicking a module in any library will automatically send it to the 
Process Flow Design window, and connect it to a selected module in the flow. 
 

 
Base Module Library Overview 
 
Layout Operation: 

 
Post Processing 

 
Process Correction 

 
Verification 

 
Control 
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2. Converting Patterns QUICK START 
 
1. For short run conversions you could use a Windows machine to run LayoutBEAMER.  This is 
accomplished by starting a session of Exceed or XMing, putty over to your korat or minx 
account and type LayoutBEAMER 
NOTE: Longer conversions, or any PEC related work, you must use use the SUN Rays. You can 
let the conversion run in the background. Log into korat or minx through a SunRay and type 
LayoutBEAMER 
 
2. Drag & Drop the Import Module from the Module Library into the Process Flow Design area 
workspace. Navigate to a folder with your GDSII file. Either accept the default Import Layout 
settings (Layer Set * & Datatype Set *) which means all available layers will be imported, or 
choose the layers you wish to import. Execute the Import module by selecting Run To from the 
module option menu with a right mouse button click on the Import module as below. Following 
completion the icon dot will turn into . 
 
3. Drag & drop the Extract module into the Process Flow Design area workspace, dropping it 
directly on top of the In GDS module, releasing the Extract module when the In GDS module 
output port turns black as shown below. 

 
In GDS and Extract modules appear connected as 

 
 
Choose a cell, layer and datatype range, select extents (automatic extent is default). Click OK. 
The modules appear as: 

 
 
Right click Extract select Run To. The modules appear as: 

 
 
To view data right click Extract select View Layout. 
 
 
 
 



Page | 7  
May 13, 2010 

4. Drag & drop the Export module on top of Extract.  Click Browse for other folders in the 
Save File window.  
 
 

 
 
 
 
In the expanded Save File window, type in a file name, navigate to the correct folder, choose 
JEOL 52 file (*.v30), and click Save (steps 1-4 in the below figure).  
 
 

 
 
 
For the JEOL, in the General tab make sure that the machine type is either JBX-9300FS (100kV)  
or JBX6300FS. Choose appropriate pattern units and shot pitch units. Fracture Mode 1 is the 
typical fracturing mode. Fracture Mode 2 uses the algorithm developed by Don Tennant at 
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Lucent that snaps ebeam pixels to pattern edges. Consequently within this mode increased 
number of fractured shapes are produced. When mapping layers to shot modulated clocks, within 
the Advanced tab, under Dose Mapping, choose Layer to Class. 
 
Fixed main field option stacks fields in a boustrophedonic/serpentine/meander manner, whereas 
Floating allows placement of the main fields such that the structures are written with minimal 
stage movement for the areas of interest. 
 
For the JBX63000FS: After choosing JBX-6300FS under the Machine Type settings under the 
General tab.  Click on the Tool tab, choose: 

EOS Mode 3  4th  Lens mode, 500um field size, 1nm pixels 
EOS Mode 6  5th  Lens mode, 62.5um field size, 0.125nm pixels 

Then go back to the General tab and modify settings. 
 
 Right click Export select Run To. 
 
 
FILE TRANSFER TO JEOL6300 
 
ftp jeol6300 
user name: jeoleb 
password: Jeoleb 
cd pattern/user 
bin 
put FileName.v30 
 
 
 
FILE TRANSFER TO JEOL9300 
 
ftp jeol 
user name: ebtest 
password: EBtest 
cd pattern/user 
bin 
put FileName.v30 
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3. PROX correction QUICK START 
 
Complete steps 1-3 in section 2. Drag & drop the PEC module on top of Extract.   
 
General tab: With “Gaussian Approximation” enabled, enter the Beta and Eta parameters.  
Checking “Include Short Range Correction” enables the Alpha parameter. At 2nA or lower on 
the JEOL Beam FWHM[um] parameter is around 0.004. 
 
Computing the parameters using SCELETON generated data: Choose “Numerical PSF”, click 
Browse and select the SCELETON xrz file (see next section on generating a SCELETON file).  
Set the Beam FWHM[um] to the appropriate beam diameter (at 2nA, the beam diameter is 
around 5nm).  Within the Accuracy tab, within Dose Class Definition, default Accuracy setting: 
PEC will only generate the number of dose classes needed to get the defined accuracy. The 
default setting is 1% with the max number of 256 dose classes. This means that you will get less 
dose classes if the accuracy of 1% can be reached by lower number of dose classes. Choosing 
Fixed Number allows user defined number of dose classes, default is 64 dose classes. The 
isodose grid defines the grid between adjacent doses. For Manhattan geometries a minimum 
figure size can be specified. Click OK. 
 
Click OK. Right click PEC select Run To. To view 
the proximity corrected pattern, right click PEC 
select View Layout. Within the Layout Viewer 
choose View > Color by Layer > Dose. 
 
Export data (see Section 2 item 4).  For the JEOL, 
exporting a v30 file will automatically generate a jdi 
file containing modulated doses (see below). Paste 
this data into the job file. 
MOD001: MODULAT (( 0, 19.17 ) , ( 1, 20.00 ) , ( 2, 20.85 ) 
-     , ( 3, 21.69 ) , ( 4, 22.55 ) , ( 5, 23.41 ) 
-     , ( 6, 24.28 ) , ( 7, 25.15 ) , ( 8, 26.03 ) 
-     , ( 9, 26.91 ) , ( 10, 27.81 ) , ( 11, 28.70 ) 
-     , ( 12, 29.61 ) , ( 13, 30.52 ) , ( 14, 31.43 ) 
-     , ( 15, 32.36 ) , ( 16, 33.29 ) , ( 17, 34.22 ) 
-     , ( 18, 35.17 ) , ( 19, 36.11 ) , ( 20, 37.07 ) 
-     , ( 21, 38.03 ) , ( 22, 39.00 ) , ( 23, 39.98 ) 
-     , ( 24, 40.96 ) , ( 25, 41.95 ) , ( 26, 42.95 ) 
-     , ( 27, 43.95 ) , ( 28, 44.96 ) , ( 29, 45.98 )  
-     , ( 30, 47.01 ) , ( 31, 48.04 ) , ( 32, 49.08 )  
-     , ( 33, 50.13 ) , ( 34, 51.18 ) , ( 35, 52.24 ) 
-     , ( 36, 53.31 ) , ( 37, 54.39 ) , ( 38, 55.47 ) 
-     , ( 39, 56.56 ) , ( 40, 57.66 ) , ( 41, 58.77 ) 
-     , ( 42, 59.89 ) , ( 43, 61.01 ) , ( 44, 62.14 ) 
-     , ( 45, 63.28 ) , ( 46, 64.43 ) , ( 47, 65.58 ) 
-     , ( 48, 66.74 ) , ( 49, 67.92 ) , ( 50, 69.09 ) 
-     , ( 51, 70.28 ) , ( 52, 71.48 ) , ( 53, 72.68 ) 
-     , ( 54, 73.90 ) , ( 55, 75.12 ) , ( 56, 76.35 ) 
-     , ( 57, 77.58 ) , ( 58, 78.83 ) , ( 59, 80.09 ) 
-     , ( 60, 81.35 ) , ( 61, 82.63 ) , ( 62, 83.91 ) 
-     , ( 63, 85.20 )) 
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4. SCELETON QUICK START 
Log into korat through a SunRay NOTE: On minx sceleton command is sceleton32 
Also SunRays must be used for sceleton. 
Copy sceleton.mda and sceleton.rsc from ~rob.ilic/public/sceleton into a directory where 
sceleton will run. Typing cp ~rob.ilic/public/sceleton/sceleton.* . will copy both files into your 
current working directory. 
 
30nmHSQsoi.sip example file 
#----------------------------------------------- 
# Sceleton run for Rob (rob@cnf.cornell.edu)  
# SOI - 110nm SiN on top of 1um SiO2 
# 
ResultFileName            30nmHSQsoi 
StackDescFileName     30nmHSQsoi 
InjectionEnergy/eV      100000.0 
ElectronsToTrace         3000000 
Verbosity               2 
IntervalInfo/s          60.0 
IntervalWrite/s         600.0 
#----------------------------------------------- 
NOTE: Compiling this .sip file will read in 30nmHSQsoi.stk and generate 30nmHSQsoi.srz for 
3 million 100keV electrons, it will display results every 60seconds, and write results to file every 
600 sec. 
 
30nmHSQsoi.stk example file    30nm HSQ on top of SOI (110nm Si/ 3um SiO2/Si substrate) 
#---------------------------------------------------------- 
StackDescriptor:        HSQ/SOI  
NumberOfLayers:         4  
#---------------------------------------------------------- 
MaterialDescriptor:     HSQ 
Thickness/nm:           30 
LayFlag:                1  
#---------------------------------------------------------- 
MaterialDescriptor:     Si  
Thickness/nm:           110 
LayFlag:                0  
#---------------------------------------------------------- 
MaterialDescriptor:     SiO2 
Thickness/nm:           3000 
LayFlag:                0 
#---------------------------------------------------------- 
MaterialDescriptor:     Si 
Thickness/nm:           700000  
LayFlag:                0 
#---------------------------------------------------------- 
NOTE: Layer thickness is expressed in nm.  LayFlag = 1 for the resist layer. 
 
sceleton 30nmHSQsoi.sip  generates 30nmHSQsoi.srz (defined by ResultFileName) 
(NOTE: on minx the command would be sceleton32 30nmHSQsoi.sip) 
 
Extract the data half-way through the plane of the resist, in this case 15nm: 
sceleton 30nmHSQsoi.srz 15  generates 30nmHSQsoi_z15.xrz 
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5A. LAYOUT BEAMER TONE REVERSAL QUICK START - Method 1 
 
You should have a bounding box around your features.  The bounding layer must be different 
than the feature layer.  As an example, consider 10 x 10 array of circles (red layer) with a 
bounding box (green layer). 
 

 
 
1. Drag & Drop 2 instances of the Import module and choose the same gds file (see below 
figure). Right click each Import and select Run To. Layout BEAMER will appear as: 
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2. Drag & Drop 2 instances of the Extract module over the existing Import modules. To 
accomplish this, drag and drop a module from the library onto the target module in the flow until 
the small white connection port turns black, then release the mouse and the modules will be 
connected. 
 

 
 
Over the left Extract choose the bounding layer and boundary cell, over the right Extract 
choose your data layer and respective cell, then click OK. 
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Right click each Extract and select Run To. The screen should appear as: 
 

 
 
 
3. Drag & Drop the left side of the Minus module over the left Extract and the right side of the 
Minus module over the right Extract. Right click Minus and select Run To (see left figure 
below). Right click Minus and choose View Layout, then View -> Fill Shapes (right figure 
below shows the output of the MINUS operation) 
 

 
 
4. Drag & drop the Export module on top of Minus.  Choose the file format (most likely GDS). 
Right click Export select Run To. 
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5B. LAYOUT BEAMER TONE REVERSAL QUICK START - Method 2 

 
This method does not need a drawn bounding box.  Pattern extents are user defined. 
 
1. Drag & Drop an instance of the Import module and choose a gds file. Drag & drop an 
instance of the Extract module over the Import module. To accomplish this, drag and drop a 
module from the library onto the target module in the flow until the small white connection port 
turns black, then release the mouse and the modules will be connected. 
 

 
Right click on Import and select Run To. Drag & drop an instance of the Extract module over 
the Import module. Choose the cell and layer within the Extract tab. Click on the Extent tab.  
Default extents are Automatic extents defined by your pattern.  Click User to manually specify 
user extents for the Boolean operation. 
 
 
2. Drag & Drop an instance of the NOT module on top of the Extract module. Right click on 
NOT and select Run To (see left figure below). Right click on NOT and select View Layout, 
then View -> Fill Shapes (right figure below displays the output of the NOT operation). 
 
 

 
 
 
Drag & drop the Export module on top of NOT.  Choose the file format (most likely GDS). 
Right click Export select Run To. 
 


